Posted by: Camilo Torres | January 22, 2009

Starting MTA: exim4, se tarda…

Cuando arranca, Debian inicia un MTA, por defecto exim4. Se ve el mensaje que dice Starting MTA: y luego de un ratico aparece exim4.

Me incomodaba que se tarada tanto, así que investigué un poco y conseguí una solución para mejorar el tiempo de arranque de exim4 y así mejorar el tiempo de arranque completo de Debian:

dpkg-reconfigure exim4-config -p low

En todas las preguntas elegí la respuesta por defecto, menos en una que indica si desea desactivar la consultas DNS en el arranque: aquí hay que decirle que si para que ignore esas consultas.

El resultado es que ahora carga mucho más rápido y el boot en general es rápido también.


Responses

  1. ¡Hola! ¿Qué tal?

    Uso Debian Etch y no me funcionó la solución que propones. No sé porqué demora tanto… =(

    ¿Qué pasa si desactivo el MTA?

  2. No pasa nada, algunas aplicaciones de linux esperan que tengas un MTA activo en el sistema, pero en principio no debería importar. Desactívalo y si falla algo importante, pues lo vuelves a activar.

  3. Lo desactivé y demora menos que antes, pero aún sigue sin convencerme. =P

    “En todas las preguntas elegí la respuesta por defecto, menos en una que indica si desea desactivar la consultas DNS en el arranque: aquí hay que decirle que si para que ignore esas consultas.”

    En realidad, nunca pregunta si se desea desactivar las consultas DNS sino si se quiere mantener las consultas DNS al mínimo, y eso es a lo que le puse que si y no pasó nada.

    Ya no sé qué más probar. =(

  4. Vas a tener que leer y buscar más, ya que al parecer tu problema es distinto que el mío. Supongo que ya buscaste en google:

    starting mta: exim4

    Fue lo que yo hice para conseguir una solución.

    He leído que siempre tienes que tener un MTA, que puede ser exim4 y otro más ligero. También puedes tenerlo instalado pero desabilitarlo en el inicio:

    update-rc.d -f exim4 remove

    o puedes intentar con otro MTA como esmtp que se levanta solo cuando es requerido.

    Lee estos mensajes:
    http://groups.google.com/group/linux.debian.user/browse_thread/thread/de1d1b27d247b82c

  5. Bueno, opté por “update-rc.d -f exim4 remove” y ya no lo carga al inicio.

    Si llegara a tener algún problema, buscaré otros MTA’s para probar.

    ¡Muchas gracias!

    ¡Saludos desde Uruguay! =D

  6. Hola, me gustaría saber que pasa si tengo más de un MTA instalado por defecto….
    Y como se puede provar…
    A ver si alguien me puede ayudar


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: